BarCode

An NDoc Documented Class Library

BarCode Namespace

Namespace hierarchy

Classes

Class | Description
BarcodeConverter128 | Code 128 Convert an input string to the equivilant string including start and stop characters. This object compresses the values to the shortest possible code 128 barcode format
BarcodeConverter39 | Code 39 Convert an input string to the equivilant string including start and stop characters.


BarcodeConverter128 Class

Code 128 Convert an input string to the equivilant string including start and stop characters. This object compresses the values to the shortest possible code 128 barcode format

For a list of all members of this type, see BarcodeConverter128 Members.

System.Object
BarcodeConverter128

public static class BarcodeConverter128

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: BarCode

Assembly: Barcode (in Barcode.dll)

See Also

BarcodeConverter128 Members | BarCode Namespace


BarcodeConverter128 Members

BarcodeConverter128 overview

Public Static Methods

StringToBarcode Converts an input string to the equivilant string, that need to be produced using the 'Code 128' font.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BarcodeConverter128 Class | BarCode Namespace


BarcodeConverter128 Methods

The methods of the BarcodeConverter128 class are listed below. For a complete list of BarcodeConverter128 class members, see the BarcodeConverter128 Members topic.

Public Static Methods

StringToBarcode Converts an input string to the equivilant string, that need to be produced using the 'Code 128' font.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BarcodeConverter128 Class | BarCode Namespace


BarcodeConverter128.StringToBarcode Method

Converts an input string to the equivilant string, that need to be produced using the 'Code 128' font.

public static string StringToBarcode(
String value
);

Parameters

String
String to be encoded

Return Value

Encoded string start/stop and checksum characters included

See Also

BarcodeConverter128 Class | BarCode Namespace


BarcodeConverter39 Class

Code 39 Convert an input string to the equivilant string including start and stop characters.

For a list of all members of this type, see BarcodeConverter39 Members.

System.Object
BarcodeConverter39

public static class BarcodeConverter39

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: BarCode

Assembly: Barcode (in Barcode.dll)

See Also

BarcodeConverter39 Members | BarCode Namespace


BarcodeConverter39 Members

BarcodeConverter39 overview

Public Static Methods

StringToBarcode Overloaded. Converts an input string to the equivilant string, that need to be produced using the 'Code 3 de 9' font.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BarcodeConverter39 Class | BarCode Namespace


BarcodeConverter39 Methods

The methods of the BarcodeConverter39 class are listed below. For a complete list of BarcodeConverter39 class members, see the BarcodeConverter39 Members topic.

Public Static Methods

StringToBarcode Overloaded. Converts an input string to the equivilant string, that need to be produced using the 'Code 3 de 9' font.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BarcodeConverter39 Class | BarCode Namespace


StringToBarcode Method

An NDoc Documented Class Library

BarcodeConverter39.StringToBarcode Method

Converts an input string to the equivilant string, that need to be produced using the 'Code 3 de 9' font.

Overload List

Converts an input string to the equivilant string, that need to be produced using the 'Code 3 de 9' font.

public static string StringToBarcode(String);

Converts an input string to the equivilant string, that need to be produced using the 'Code 3 de 9' font.

public static string StringToBarcode(String,Boolean);

See Also

BarcodeConverter39 Class | BarCode Namespace


BarcodeConverter39.StringToBarcode Method (String)

Converts an input string to the equivilant string, that need to be produced using the 'Code 3 de 9' font.

public static string StringToBarcode(
String value
);

Parameters

String
String to be encoded

Return Value

Encoded string start/stop characters included

See Also

BarcodeConverter39 Class | BarCode Namespace | BarcodeConverter39.StringToBarcode Overload List


BarcodeConverter39.StringToBarcode Method (String, Boolean)

Converts an input string to the equivilant string, that need to be produced using the 'Code 3 de 9' font.

public static string StringToBarcode(
String value,
Boolean addChecksum
);

Parameters

String
String to be encoded
Boolean
Is checksum to be added

Return Value

Encoded string start/stop and checksum characters included

See Also

BarcodeConverter39 Class | BarCode Namespace | BarcodeConverter39.StringToBarcode Overload List


Hierarchy

System.Object
BarCode.BarcodeConverter128
BarCode.BarcodeConverter39

See Also

BarCode Namespace